SUSE Linux iTOps Tube

Wednesday, May 9, 2012

swap read error on hibernate.

When attempt to hibernate my my system I start getting a bunch of swap read errors after it syncs my drive. I am running on a combination Ramdisk and flash file system. I am only using the drive as a swap to try and test out hibernation (suspend to disk). I am running on a system with an LSI SATA controller and LSI driver is built into the kernel.




Code:


~ # swapon /dev/sda1

~ # swapon -s

Filename                                Type            Size    Used    Priority

/dev/sda1                              partition      4016064 0      -1

~ # echo disk > /sys/power/state

Freezing user space processes ... (elapsed 0.01 seconds) done.

Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.

Suspending console(s) (use no_console_suspend to debug)

sd 0:0:0:0: [sda] Synchronizing SCSI cache

end_request: I/O error, dev sda, sector 319

Read-error on swap-device (8:0:447)

end_request: I/O error, dev sda, sector 447

Read-error on swap-device (8:0:575)

end_request: I/O error, dev sda, sector 575

Read-error on swap-device (8:0:703)

end_request: I/O error, dev sda, sector 703

Read-error on swap-device (8:0:831)

end_request: I/O error, dev sda, sector 831

Read-error on swap-device (8:0:959)

end_request: I/O error, dev sda, sector 959

Read-error on swap-device (8:0:1087)

end_request: I/O error, dev sda, sector 1087

Read-error on swap-device (8:0:1215)

...













No comments:

Post a Comment